We have identified a delay with retrieving our NBDR API documents.

Major incident News, blogs, discussions and reviews API
2023-03-30 08:37 IDT · 5 minutes

Updates

Investigating

We are aware of the current incident affecting our services and would like to inform you that our team is actively investigating the issue

March 30, 2023 · 08:48 IDT
Issue

We are currently investigating an issue with the NBDR API. For the time being there is a delay with retrieving our NBDR documents.

March 30, 2023 · 08:38 IDT

← Back